Page 2 of 2 FirstFirst 12
Results 21 to 28 of 28

Thread: Engine Stalls when I hit a puddle in the rain

  1. #21
    Van Enthusiast
    My Van(s):
    97 Previa DX SC AWD...alive! 95 Previa LE SC AWD (RIP) 93 Previa LE AWD (rustbucket w/ no reverse...parts van) 91 Previa LE AWD (RIP)
    Join Date
    Nov 2014
    Location
    Midwest/Southwest/Northwest
    Posts
    222
    Rep Power
    1

    Re: Engine Stalls when I hit a puddle in the rain

    My check engine light has been on since 1998.

  2. #22
    Administrator timsrv's Avatar
    My Van(s):
    Lots of them
    Join Date
    Jun 2010
    Location
    SW WA ST
    Posts
    6,095
    Rep Power
    10

    Re: Engine Stalls when I hit a puddle in the rain

    Huh? I was going off this information you previously posted:

    Quote Originally Posted by Previologist View Post
    Brand new cap and 0-ring less than 15,000 miles ago so i don't think it is that.



    Hmmm, interesting thought which I would normally rule out except...the other day my ECU apparently lost power briefly. I started the van and my check engine light didn't come on................

  3. #23
    Van Enthusiast
    My Van(s):
    97 Previa DX SC AWD...alive! 95 Previa LE SC AWD (RIP) 93 Previa LE AWD (rustbucket w/ no reverse...parts van) 91 Previa LE AWD (RIP)
    Join Date
    Nov 2014
    Location
    Midwest/Southwest/Northwest
    Posts
    222
    Rep Power
    1

    Re: Engine Stalls when I hit a puddle in the rain

    Oh, I had already forgotten about that. Whatever it was it only happened once and never happened again. That CEL is back to staring at me all the time, including when its just in the ON position and not running.

  4. #24
    Administrator timsrv's Avatar
    My Van(s):
    Lots of them
    Join Date
    Jun 2010
    Location
    SW WA ST
    Posts
    6,095
    Rep Power
    10

    Re: Engine Stalls when I hit a puddle in the rain

    Yeah, these type problems can be very frustrating. I have no problem zoning in on problems when they remain. It's the intermittent ones that I hate.....because they will never be there when you are looking for them. At least you know it's not the ECU power circuit. I would suggest removing the passenger seat and access panel, then use a spray bottle of water to try and duplicate the issue. I would start low and work your way up. Try to focus on small areas so you can zero in on the trouble area. As you're wetting it down, look for sparks jumping in wet areas. If it stalls, pull the dist cap immediately to see if any water has infiltrated. Tim

  5. #25
    Van Enthusiast
    My Van(s):
    97 Previa DX SC AWD...alive! 95 Previa LE SC AWD (RIP) 93 Previa LE AWD (rustbucket w/ no reverse...parts van) 91 Previa LE AWD (RIP)
    Join Date
    Nov 2014
    Location
    Midwest/Southwest/Northwest
    Posts
    222
    Rep Power
    1

    Re: Engine Stalls when I hit a puddle in the rain

    Great idea. I will try that before and after I change the cap, rotor and add a new heat insulator if I can find one for a non-exhorbitant price

  6. #26
    Van Enthusiast
    My Van(s):
    97 Previa DX SC AWD...alive! 95 Previa LE SC AWD (RIP) 93 Previa LE AWD (rustbucket w/ no reverse...parts van) 91 Previa LE AWD (RIP)
    Join Date
    Nov 2014
    Location
    Midwest/Southwest/Northwest
    Posts
    222
    Rep Power
    1

    Re: Engine Stalls when I hit a puddle in the rain

    Quote Originally Posted by timsrv View Post
    Yeah, these type problems can be very frustrating. I have no problem zoning in on problems when they remain. It's the intermittent ones that I hate.....because they will never be there when you are looking for them. At least you know it's not the ECU power circuit. I would suggest removing the passenger seat and access panel, then use a spray bottle of water to try and duplicate the issue. I would start low and work your way up. Try to focus on small areas so you can zero in on the trouble area. As you're wetting it down, look for sparks jumping in wet areas. If it stalls, pull the dist cap immediately to see if any water has infiltrated. Tim

    You're the man. It is the coil, not the distributor. I haven't taken it off yet so I don't know why, but I covered the distributor with foil and sprayed only the coil and boom it dies.

    Edit/update: seems to be centered at the connector coming to the coil from battery, but can't see anything wrong yet.
    Last edited by Previologist; 06-28-2022 at 02:37 PM.

  7. #27
    Van Enthusiast
    My Van(s):
    97 Previa DX SC AWD...alive! 95 Previa LE SC AWD (RIP) 93 Previa LE AWD (rustbucket w/ no reverse...parts van) 91 Previa LE AWD (RIP)
    Join Date
    Nov 2014
    Location
    Midwest/Southwest/Northwest
    Posts
    222
    Rep Power
    1

    Re: Engine Stalls when I hit a puddle in the rain

    That power-in line was the only one I wasn't able to get off when I greased the others a few days ago, because I didn't take the coil off when I did it. Today I took the coil off, liberally greased the outside of the tower that the power-in connector slides over, and that did the trick. Spraying it with water has no effect now.

    I think I can finally drive in the rain again. Thanks for the great idea Tim!

  8. #28
    Administrator timsrv's Avatar
    My Van(s):
    Lots of them
    Join Date
    Jun 2010
    Location
    SW WA ST
    Posts
    6,095
    Rep Power
    10

    Re: Engine Stalls when I hit a puddle in the rain

    I think a banana dance is in order

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •