Page 2 of 2 FirstFirst 12
Results 21 to 39 of 39

Thread: Another rough idle question

  1. #21
    Van Enthusiast
    My Van(s):
    1986 LE
    Join Date
    Aug 2017
    Location
    Florida
    Posts
    150
    Rep Power
    1

    Re: Another rough idle question

    Yea, I did it a while ago, before I relocated it back to its home.
    However it seems to work fine. When cold she will race north of 1200RPM then settle down to idle. The problem is in this early stage of warm up the idle after the valve closes almost stalls. Again, if I feather it she will hang until another 5 minutes. Then she is OK, but after another say 20 highway driving she will race at 1500 at idle. Then start it again 10 minutes later and she idles very low and shakes. So that is the delta, from almost stall to 1500RpM. If I leave along too long she will eventfully stall. Go figure.
    I will try the pitch test again just to make sure I have it all covered.
    Thank Tim

    MT

  2. #22
    Van Enthusiast
    My Van(s):
    1986 LE
    Join Date
    Aug 2017
    Location
    Florida
    Posts
    150
    Rep Power
    1

    Re: Another rough idle question

    OK, moving forward on my idle issues. Ready to remove the throttle body. Does anyone know where one can find a gasket for it? I hunted around Rock and others and could not find it anywhere.

    Thanks
    MT

  3. #23
    Administrator timsrv's Avatar
    My Van(s):
    Lots of them
    Join Date
    Jun 2010
    Location
    SW WA ST
    Posts
    5,830
    Rep Power
    10

    Re: Another rough idle question

    If you're pulling the throttle body take a look at THIS THREAD. The Toyota part number for that gasket is at the bottom of the 1st post. Last time I needed one Toyota still had them. Good luck . Tim

  4. #24
    Van Enthusiast
    My Van(s):
    1986 LE
    Join Date
    Aug 2017
    Location
    Florida
    Posts
    150
    Rep Power
    1

    Re: Another rough idle question

    Hey Tim:
    Thanks. I must have looked through this thread 50 times and I missed it.
    I found one on amazon but paid $15 bucks for it

    Thanks again.

    I did do some more trouble shooting prior to the throttle body work. I ran some volt meters on all the VSV's. The ISV was one in question. Turns out I am seeing no voltage going to this VSV when monitored under every condition. There is no real explanation of what this does but it is part of the vacuum system on the throttle body. I will look closer this weekend before I pull the throttle body off.

    Should be fun!

    MT

  5. #25
    Van Enthusiast
    My Van(s):
    1986 LE
    Join Date
    Aug 2017
    Location
    Florida
    Posts
    150
    Rep Power
    1

    Re: Another rough idle question

    Getting ready to pull the throttle body off I lose one cylinder again for the third time. So off comes the intake to get them out and sure enough it is what I now call " The Injector of Death". Thought Tim would like that one. But really this is a joke. So I am making ready to do the filter mod. Here is shot of the dirty injector. I also found this thing on the driver side of the intake with a little tube on it. Anyone know what it is? I will continue to dig through threads and stuff to define this.


    MT
    Attached Images Attached Images    

  6. #26
    Van Enthusiast
    My Van(s):
    1987 Toyota 4wd Cargo Van
    Join Date
    Aug 2016
    Location
    Lakeside, Az.
    Posts
    174
    Rep Power
    0

    Re: Another rough idle question

    Pretty sure thats just a vacuum filter...

    Theres a diagram in this pot that shows that item:
    https://www.toyotavantech.com/forum/...=vacuum+switch

  7. #27
    Van Enthusiast
    My Van(s):
    1986 LE
    Join Date
    Aug 2017
    Location
    Florida
    Posts
    150
    Rep Power
    1

    Re: Another rough idle question

    Fantastic Tim:

    Wow, this is a nice diagram to boot. But it explains so much.

    OK, on my way to new fuel filters.

    MT

  8. #28
    Van Enthusiast
    My Van(s):
    1986 LE
    Join Date
    Aug 2017
    Location
    Florida
    Posts
    150
    Rep Power
    1

    Re: Another rough idle question

    Ouch: Just spotted the link was sent by Flecker. Thank you.

    MT

  9. #29
    Van Enthusiast
    My Van(s):
    1986 LE
    Join Date
    Aug 2017
    Location
    Florida
    Posts
    150
    Rep Power
    1

    Re: Another rough idle question

    Pulled my injectors out and although #3 is full of rust, 1,2 ,4 are not very pretty either.

    Can somebody provide the contact info for Dr Injector? These injectors have less than 5K miles on them, so I think if I get them checked and repaired I will be in good shape.

    Thanks

    MT

  10. #30
    Administrator timsrv's Avatar
    My Van(s):
    Lots of them
    Join Date
    Jun 2010
    Location
    SW WA ST
    Posts
    5,830
    Rep Power
    10

    Re: Another rough idle question

    Just do a Google search for "injector ultrasonic cleaning Florida (your city)". I'd do it for you, but don't know your city. Tim

  11. #31
    Van Enthusiast
    My Van(s):
    1986 LE
    Join Date
    Aug 2017
    Location
    Florida
    Posts
    150
    Rep Power
    1

    Re: Another rough idle question

    Tim:

    Got it!

    Thanks a bunch.

    MT

  12. #32
    Van Enthusiast
    My Van(s):
    88 4wd
    Join Date
    Apr 2017
    Location
    Oakland
    Posts
    110
    Rep Power
    1

    Re: Another rough idle question

    Quote Originally Posted by MyToy View Post
    Hey Tim:
    Thanks. I must have looked through this thread 50 times and I missed it.
    I found one on amazon but paid $15 bucks for it

    Thanks again.

    I did do some more trouble shooting prior to the throttle body work. I ran some volt meters on all the VSV's. The ISV was one in question. Turns out I am seeing no voltage going to this VSV when monitored under every condition. There is no real explanation of what this does but it is part of the vacuum system on the throttle body. I will look closer this weekend before I pull the throttle body off.

    Should be fun!

    MT
    Hi there - got a link to the gasket on amazon? All the ones I'm seeing are discontinued... :/

  13. #33
    Administrator timsrv's Avatar
    My Van(s):
    Lots of them
    Join Date
    Jun 2010
    Location
    SW WA ST
    Posts
    5,830
    Rep Power
    10

    Re: Another rough idle question

    Just had this conversation on another thread:


  14. #34
    Van Enthusiast
    My Van(s):
    88 4wd
    Join Date
    Apr 2017
    Location
    Oakland
    Posts
    110
    Rep Power
    1

    Thumbs up Re: Another rough idle question

    Quote Originally Posted by timsrv View Post
    Just had this conversation on another thread:
    Thank you!

  15. #35
    Van Enthusiast
    My Van(s):
    1986 LE
    Join Date
    Aug 2017
    Location
    Florida
    Posts
    150
    Rep Power
    1

    Re: Another rough idle question

    Found the source of the rust getting to Cyl #3. After removing the stock filter , that had 3000 miles on it, looked like it was throwing up blood from its input side. All over the bench, clothes, papers, you get the idea. Was a short walk to pulling the tank. I thought I had already confirmed it was not the tank but when I removed the fuel pump and dropped an LED super bright down there the story was told. Especially on the ceiling of the tank. It was caked with rust and it was falling from the none fuel touching areas.
    So brought the tank to a radiator shop that had some experience with this. They cut a hole in the bottom and treated it with chemicals and power washed. It is about 95% better now. Very little left up there. So she goes back in today.

    I figured the fuel damper, since it is the firs thing that gets hit as the fuel comes from the tank, should be replaced. However when received from RockAuto (Standard Motor FPD3) it would not thread into the fuel rail. It goes about a turn and a half and gets stuck. The old one looks the same. So not sure what to do. It seems like this is the only one that can replace the 23270 Part Toyota calls out for.

    Anyone have any other replacements or should I just try to flush the old one out and use it?

  16. #36
    Van Obsessed
    My Van(s):
    1988 4WD LE auto dual range t-case (the mistress) 1988 4WD LE auto(the donut van)
    Join Date
    Aug 2012
    Location
    Tacoma, Wa
    Posts
    501
    Rep Power
    1

    Re: Another rough idle question

    Have a look at this.

  17. #37
    Van Enthusiast
    My Van(s):
    1986 LE
    Join Date
    Aug 2017
    Location
    Florida
    Posts
    150
    Rep Power
    1

    Re: Another rough idle question

    Fantastic!

    I will get it and dye it.

    MT

  18. #38
    Van Enthusiast
    My Van(s):
    1986 LE
    Join Date
    Aug 2017
    Location
    Florida
    Posts
    150
    Rep Power
    1

    Re: Another rough idle question

    A bit of an update on this. I got a hold of the correct die and cleaned it up. Now she was able to get in the fuel tube without any real issues. Continuing to put this puppy back together the next stage was to flush all the lines out with new super filter Tim suggested, then onward to intake manifold. After installed I proceeded to put back the EGR. As I carried over to the van I spotted something. There was a hair line crack down the to tube to the exhaust connection. Sanding it down a bit reveal the level of crack. Took a compressor to it and it leaked very bad. This may be another reason why the engine ran rough and was not consistently the same at idle. Not sure. But for those of you that are questioning any of this, you may want to look at it. Picture attached.

    MT
    Attached Images Attached Images  

  19. #39
    Forum Newbie
    My Van(s):
    1986 Toyota Cargo Van (Automatic)
    Join Date
    Dec 2018
    Location
    Ontario, Canada
    Posts
    8
    Rep Power
    0

    Question Re: Another rough idle question

    The van I bought (86' 2wd auto) has been running fairly well apart from a few things in particular.

    It has an extended crank when cold which I'm fairly sure is probably just the injector time switch which I may or may not bother to do but more importantly is that when I get gas the van doesn't really want to start and when it does it idles extremely low and poorly. I usually hold my foot on the gas and bring the idle up a bit to help it but it's not great, if you leave it for a few minutes running it clears up entirely.

    I'm not sure if it's related but it also does this very same thing when you park it on a hill and turn it off, although it takes much longer while on a hill before it starts to run better. It doesn't matter if it's pointing upwards or downwards on said hill, just an incline of some sort (a huge pain when your driveway is on an angle towards the road).
    Not looking forward to the winter time in a few months when I can't park it on the road if I can't clear this up :/

    What do you gurus think? Residual check valve in the fuel pump for the hill issue? Some emissions vent valve or just bad gas cap for the fuel up issue?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •