Results 1 to 2 of 2

Thread: Townace catalytic converter light on (but wasn't CC)

  1. #1
    Administrator
    My Van(s):
    89' TownAce Auto 87' 4x4 5spd LE 87’ 4x4 5spd Cargo
    Join Date
    Mar 2014
    Location
    SEATTLE, WA
    Posts
    1,976
    Rep Power
    10

    Townace catalytic converter light on (but wasn't CC)

    This looks to be the appropriate thread for the issue that just arised today as I'm sitting on the freeway waiting for a AAA flatbed,

    My TownAce just stopped accelerating from 105km (60mph) and began to slow down and then the catalytic converter light came on so I pulled over. I had all the kids in the van with me but luckily my wifey was 20 minutes behind and saved them off the freeway!!!

    Van's going in the shop and looks like a new CC and 02 sensors are in order and maybe ask them to replace the TPS while they have it. I'll post the results when it's all done.

    By the way the TownAce is a 3Y 2.0 motor so finding a CC shouldn't be a issue, not sure if diesels have a different CC?

    JDM

  2. #2
    Administrator
    My Van(s):
    89' TownAce Auto 87' 4x4 5spd LE 87’ 4x4 5spd Cargo
    Join Date
    Mar 2014
    Location
    SEATTLE, WA
    Posts
    1,976
    Rep Power
    10

    Re: Townace catalytic converter light on (but wasn't CC)

    Sorry I took so long to update, they didn't pull codes for the issues even after described them, they did a recreation diagnosis and came up with it was misfiring and needed to replace the ignition coil, cap and rotor. Didn't have to do anything with the CC even though my CC overheat light came on, I've been driving the van ever since and took that trip back out to Federal Way where the van broke down and it was smooth van'ng!!!
    Attached Images Attached Images  

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •